修复Mac升级后IntelliJ idea报Cannot Run Git问题

业余杂谈 herman 716浏览
公告:“业余草”微信公众号提供免费CSDN下载服务(只下Java资源),关注业余草微信公众号,添加作者微信:codedq,发送下载链接帮助你免费下载!
本博客日IP超过2000,PV 3000 左右,急需赞助商。
极客时间所有课程通过我的二维码购买后返现24元微信红包,请加博主新的微信号:codedq,之前的微信号好友位已满,备注:返现
受密码保护的文章请关注“业余草”公众号,回复关键字“0”获得密码
所有面试题(java、前端、数据库、springboot等)一网打尽,请关注文末小程序
视频教程免费领

以前的小米鼠标太费电了,于是就买了一个第二代的小米鼠标,顺便把 MacOS 的系统给升级了一番,结果打开 IntelliJ IDEA 后发现 Git 无法使用了。完整错误提醒信息如下所示:

xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

Cannot Run Git

刚开始升级后,我以为是 Git 出问题了,但是试了试 SourceTree,发现没问题。

然后在 iTerm2 中尝试执行下面命令:

git --help

结果也出错。

xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

然后一通谷歌,得知需要安装 xcode-selcet

xcode-selcet 安装

然后执行 xcode-select –install 进行 command line developer tools 安装。

xcode-select --install

安装完成后,在命令行中输入 git –help,发现 git 可以使用了。然后重启 idea 开发工具,git 也可以正常使用了!

业余草公众号

最后,欢迎关注我的个人微信公众号:业余草(yyucao)!可加作者微信号1:xmtxtt(5000人已满),微信号2:xttblog(5000人已满),微信号3:codedq(超3800)。备注:“1”,添加博主微信拉你进微信群。备注错误不会同意好友申请。再次感谢您的关注!后续有精彩内容会第一时间发给您!原创文章投稿请发送至532009913@qq.com邮箱。商务合作也可添加作者微信进行联系!

本文原文出处:业余草: » 修复Mac升级后IntelliJ idea报Cannot Run Git问题